该版本的 %1 与你运行的 Windows 版本不兼容

将Android开发项目从一台机子转移到另一台机子时,运行AS后报出:

Error:CreateProcess error=216, 该版本的 %1 与你运行的 Windows 版本不兼容。请查看计算机的系统信息,然后联系软件发布者。

此问题发生的原因是AndroidStudio配置中的jdk版本与环境变量中设置的版本不一致导致的,因此解决还是从配置上着手,如下修复:

jdk

我要评论!

想一个你喜欢的昵称。
给一个你的常用邮箱。
想和萌萌哒的TA们说点啥。
  • 漏洞描述: 国外著名的远程管理软件公司NetSarang旗下多款客户端连接软件产品(Xmanager、Xshell、Xftp 和 Xlpd)被曝植入后门,存在敏感信息数据泄露风险。 漏洞定级: 高危 漏洞影响范围: 受影响版本:Xmanager Enterprise 5.0 Build 1232Xm...
  • A类:10.0.0.0-10.255.255.255 B类:172.16.0.0-172.31.255.255 C类:192.168.0.0-192.168.255.255
  • 一直以来对nginx中root、alias指令的区别没有搞清楚,今天特别查找了一些资料,同时通过实例配置nginx的方法来对比这两个指令。 一.nginx root指令 root指的是根目录,可以简单地理解为父目录。 举例: location /a/ { ...; root /www/;...} 当...
  • Android 编译时出现“finished with non-zero exit value”,这是怎么了?一直找不到原因所在,搞得整个项目都跨了。 尝试恢复解决: 1.想想你刚刚动了啥导致的?如果可以,请备份后回退到之前的状态,试着看看可能恢复; 2.如果你的 ide 提供了 clean 功能,...
  • 一、安装Tomcat和JDK 1、上传apache-tomcat-6.0.18.tar.gz和jdk-6u12-linux-i586.bin至/usr/local 2、执行如下命令安装tomcat: #cd /usr/local #tar zxvf apache-tomcat-6.0.18.tar....
微信扫一扫即可带走我!