该版本的 %1 与你运行的 Windows 版本不兼容

将Android开发项目从一台机子转移到另一台机子时,运行AS后报出:

Error:CreateProcess error=216, 该版本的 %1 与你运行的 Windows 版本不兼容。请查看计算机的系统信息,然后联系软件发布者。

此问题发生的原因是AndroidStudio配置中的jdk版本与环境变量中设置的版本不一致导致的,因此解决还是从配置上着手,如下修复:

jdk

相关推荐:
创建一个属于你自己的android.app.Application的子类,然后在manifest中申明一下这个类,这是android就为此建立一个全局可用的实例,你可以在其他任何地方使用Context.getApplicationContext()方法获取这个 …
背景信息: 近期,Linux内核曝出远程执行漏洞,并命名为“Phoenix Talon”,其中一个漏洞为严重(Critical)级别,另外三个为高危(High)。 漏洞描述: 漏洞可导致远程DOS,在符合一定利用条件下可导致远程代码 …
一般的Cookie都是从document对象中获得的,现在浏览器在设置 Cookie的时候一般都接受一个叫做HttpOnly的参数,跟domain等其他参数一样,一旦这个HttpOnly被设置,你在浏览器的 document对象中就看不到Cooki …
漏洞等级采用CVSS 2.0标准的评分原则,对单个漏洞进行基本向量评分。CVSS : Common Vulnerability Scoring System,即“通用漏洞评分系统”,是一个“行业公开标准,其被设计用来评测漏洞的严重程度,并帮助确 …
1.docker run -it 过后请别使用 CTRL+C 退出 2.使用 CTRL+P+Q 退出当前容器内部回话,就会后台运行了。 如果没解决你得问题,请尝试查看日志信息: docker logs {container_id}  
拿起手机扫一扫即可带走我!