☺️️近期我们正在更新一个新样式,希望你会喜欢!
Oracle WebLogic wls9-async组件存在反序列化远程命令执行漏洞

背景信息:

WebLogic Server是美国甲骨文(Oracle)公司开发的一款适用于云环境和传统环境的应用服务中间件,它提供了一个现代轻型开发平台,支持应用从开发到生产的整个生命周期管理,并简化了应用的部署和管理。

漏洞描述:

部分版本WebLogic中默认包含的wls9_async_response包,为WebLogic Server提供异步通讯服务。由于该WAR包在反序列化处理输入信息时存在缺陷,攻击者可以发送精心构造的恶意 HTTP 请求,获得目标服务器的权限,在未授权的情况下远程执行命令。

漏洞定级:

高危

漏洞影响范围:

该漏洞的影响版本如下:

WebLogic 10.X

WebLogic 12.1.3

扩展知识引用:

对WebLogic服务在全球范围内的分布情况进行分析,结果显示该服务的全球用户规模约为6.9万,其中位于我国境内的用户规模约为2.9万。通过技术检测,发现我国境内WebLogic用户中,共有461个网站受此漏洞影响,所占比例为1.6%。【该内容来自于CNVD官方】

漏洞处置建议:

目前,Oracle官方暂未发布补丁,临时解决方案如下:

1、 删除该war包并重启webLogic;

2、 通过访问策略控制禁止 /_async/* 路径的URL访问;

3、通过防火墙临时将暴露的端口屏蔽,如7001。

相关推荐:
背景信息: 2019年4月03日,监测到Apache 官方发布安全更新,修复了多个安全漏洞,其中包含一个严重级别的提权漏 […]
背景信息: 2019年4月02日,监测到Kubernetes官方发布安全通告,披露了一个Kubernetes API服务 […]
漏洞描述: 2019年7月03日,Kubernetes官方发布安全通告,披露了一个kubectl cp命令潜在目录穿越漏 […]
漏洞描述: 2018年4月18日,Oracle官方发布了4月份的关键补丁更新CPU(Critical Patch Upd […]
背景信息 2018年12月04日,Kubernetes官方发布安全通告,披露了一个Kubernetes API服务器特权 […]
手机扫一扫即可带走我!