☺️️近期我们正在更新一个新样式,希望你会喜欢!
Kubernetes API服务器远程特权提升漏洞(CVE-2018-1002105)

背景信息

2018年12月04日,Kubernetes官方发布安全通告,披露了一个Kubernetes API服务器特权提升漏洞CVE-2018-1002105。

漏洞描述:

通过特制请求,未经身份验证的恶意用户可以通过Kubernetes API服务器与后端服务器(例如聚合API服务器和kubelets)建立连接,然后通过同一连接将任意请求直接发送到后端,并使用Kubernetes API服务器用于建立后端连接的TLS凭证进行身份验证。进而可以窃取敏感数据或注入恶意代码,甚至控制Kubernetes集群。

漏洞定级:

高危

漏洞影响范围:

影响组件为Kubernetes API server,涉及版本为:

  1. Kubernetes v1.0.x-1.9.x
  2. Kubernetes v1.10.0-1.10.10
  3. Kubernetes v1.11.0-1.11.4
  4. Kubernetes v1.12.0-1.12.2 安全版本
  5. Kubernetes v1.10.11
  6. Kubernetes v1.11.5
  7. Kubernetes v1.12.3
  8. Kubernetes v1.13.0-rc.1

漏洞处置建议:

建议升级Kubernetes至安全版本。

扩展知识引用:

https://access.redhat.com/security/vulnerabilities/3716411https://groups.google.com/forum/#!topic/kubernetes-announce/GVllWCg6L88https://github.com/kubernetes/kubernetes/issues/71411

相关推荐:
漏洞描述: 2019年7月03日,Kubernetes官方发布安全通告,披露了一个kubectl cp命令潜在目录穿越漏 […]
背景信息: WebLogic Server是美国甲骨文(Oracle)公司开发的一款适用于云环境和传统环境的应用服务中间 […]
背景信息: 2019年4月03日,监测到Apache 官方发布安全更新,修复了多个安全漏洞,其中包含一个严重级别的提权漏 […]
漏洞描述: 2018年4月18日,Oracle官方发布了4月份的关键补丁更新CPU(Critical Patch Upd […]
背景信息: 2019年4月02日,监测到Kubernetes官方发布安全通告,披露了一个Kubernetes API服务 […]
手机扫一扫即可带走我!